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Jim2® eBusiness Framework Installation Notes 
 

Summary 

These notes provide details on installing the Happen Business Jim2 eBusiness Framework. This includes eBusiness 

Service and  eMeter Reads.  

 

Jim2 eBusiness Framework 

The Jim2 eBusiness Framework (Jef) is software that is installed on your web server to manage your website. Jim2 

eBusiness Framework communicates with Jim2 Business Engine (Jim2) via Jim2 eBusiness Server (Jes). 

 

eBusiness Service 

eBusiness Service has been developed in .Net and is an addition to our product range that allows your customers to 

add and view status of service jobs online, as well as Technicians/Engineers being able to change status, add labour 

and labour comments online. eBusiness Service Notification Services allow users to configure business alerts (emails) 

on adding or editing a Job within certain rules, ie Status Due. 

 

eMeter Reads 

 eMeter Reads, an easy, user friendly way for your clients to submit their meter reads to you via a simple webpage. 

Jim2  eMeter Reads will save you hours of data entry per month. 

 

 Meter or Page Count request emailed to your customers directly from Jim2 Business Engine. Customer enters Meter 

Reads on web page which feeds into Jim2 automatically. 

 Customisable web page Meter Read ‘entry screen’, allowing you to brand and modify web page. 

 Built in error checking to prevent end user data entry mistakes, and ensuring correct billing. 

 

Internal Hosting vs External Hosting  

The Jim eBusiness Framework can be hosted on either an internal server or an external ISP/hosting provider.  

 

Why would you choose one over the other? 

 

Internal hosting is a choice for companies that have specific requirements, and that would require them to manage 

their own servers. This option would be for companies with technical support available to manage a web server. This 

involves having a skilled technician with knowledge of IIS, Windows Servers, SQL Server, Windows Permission.  

 

Minimum Hardware Requirements 

 

 1 Ghz CPU 

 1 GB RAM  

 20 GB HDD 
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External hosting (ISP/Hosting provider) would be a good choice for many companies that do not have specific 

requirements for an internally managed server. This involves finding a hosting provider that supports Windows Server, 

ASP.NET 2.0 and SQL Server. To set up external hosting you will need to find a hosting provider and make sure they 

can conform to the follow checklist: 

 

 The ASP.NET user account needs write/delete access to the full website directory. 

 Check they have .net framework 2.0. 

 SQL Server 2000+. 

 

(Please note: as of Jim2 Version 3.3 .net framework 4.0 is required) 

 

System Requirements  

 

Web Server 

IIS must be installed and ASP .Net version 2/4 configured. You will need to create an ASP.Net web application at the 

root directory of the Jef website. 

 

Happen Business recommends that your web server be separated from all your backend services by firewall at least. It 

is highly recommended that a DMZ be used, or if this is not practical then have the website hosted by a third part 

provider (ISP). 

 

To install Jef you will need FTP or direct file access to the website's root directory. 

 

SQL Server 

Jef requires Microsoft SQL server. This can be installed on the same machine as the web server, or on another server, 

depending on the infrastructure availability. If your website is to be hosted by a third party provider the SQL Server will 

usually be installed on a separate machine. If a licence for Microsoft SQL Server is not readily available then install 

Microsoft SQL Express (2005 or 2008) on the web server. 

 

You will need to create a database for Jef. The Jef installation will set up the database as required. 

 

Jes to Jef Connectivity 

For 'online' functionality such as eBusiness Server, Jef needs to communicate with Jes via a TCP/IP connection. Your 

network must be configured in such a way to allow Jef on the web server to establish a TCP/IP connection with Jes. Jes 

is usually set up to accept a connection on port 5740, but this is configuration (see the TCP module for more 

information). 

 

Jes needs HTTP access to Jef in order to publish web logon details etc to the website. 
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Steps to Install Jes/Jef 

 

Overview 

 

Step 1. Download and Install the Latest Version of Jim2  

The lastest Jim2 Version can be found at http://www.happen.biz/LatestUpdate.aspx 

 

Step 2. Download and Install Jes.  

The Jim2 eBusiness Server (Jes) is a service that runs on the same machine as Jim2Server. It is the process into which 

modules are loaded so you can achieve the functionality you require and are licensed for. 

 

Note: Jes needs to be on the same server as Jim2 Server 

 

1. Download the latest version from the link provided from Happen, or from here. 

2. Run the installer on the computer where Jim2 Server is running. 

 

Step 3. Set up Either the WebServer or External Hosting  

 

Step 3a. Setting up a WebServer 

It is recommended that only experienced technicians set up their own webserver. This involves having a skilled 

technician with knowledge of IIS, Windows Servers, SQL Server, Windows Permission.  

 

Setup for local website hosting: 

 

1. Install IIS. 

Install .net framework 2.0 (Please note: as of version 3.3 .net framework 4.0 is required) – if .net framework 2.0 

was installed before IIS6, run 'C:\Windows\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i' from 

command prompt. 

2. Set up a SQL Server 2000. 

3. Create a New Database for the Jef installer. 

 

Step 3b. Setting up External Hosting 

To set up external hosting you will need to find a hosting provider and make sure they can conform to the follow 

checklist: 

 

 The ASP.NET user account needs write/delete access to the full website directory. 

 Check they have .net framework 2.0 (Please note: as of version 3.3 .net framework 4.0 is required). 

 SQL Server 2000+. 

 

  

http://www.happen.biz/LatestUpdate.aspx
http://www.happen.biz/LatestUpdate.aspx
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Step 4. Things you need to know before continuing.  

 

Deploy Path 

To deploy Jef to your web server you will need either file or ftp access to the root folder of the ASP.Net web 

application on the web server. 

 

If your web server is local then you will generally be able to copy the web application file to the web server via the 

network file system. 

 

If your website is hosted by a third party (ISP), then generally you will be given an ftp path and ftp logon details to use 

to copy files to the website. You need to enter these details into JefSetup so it can copy the web application files to 

your web server. 

 

Note: The directory is the location of where the website files are installed.  

Examples include ‘/happen.biz/web’ or ‘/httpdocs’. 

 

Database Connection String 

You need to enter the DB connection string for the web server database to be used by Jef. Clicking on the ... button 

allows you to enter the parameters in a user friendly manner. 

 

The details required for the connection string will either be supplied by your ISP if website is hosted, or you will know 

the details from setting up your SQL database in preparation for deploying Jef. 

 

Note: If you have been provided a server instance name you will need to enter this when asked, but if you have not 

been given this by your provider please leave blank. 

 

Jes Connectivity 

The Jef needs connectivity with Jes for certain tasks (such as retrieving a user's list of jobs). Jef connects to Jef using 

TCP/IP, so you must specify the address (either DNS Name or IP Address) of your machine where Jes is running, and 

the TCP/IP port that Jes is configured to use. 

 

Note: This is the IP or DNS of your internal network, you will also need to have a port forwarded from your firewall to 

the machine with Jes. (The default port is 5740.) 

 

Website URL 

This is the URL to the root of the Jef web application, ie the web address of the website you are about to deploy. This 

URL is used by JefSetup to verify the deployment was successful at the end of the setup process. 

 

For example: 

If Jef is to deployed to the root of your website as the main application, the URL would be like: 

http://yourcompany.com 

 

If Jef is to be deployed to a subdirectory of your website as a secondary application, the URL would be like: 

http://yourcompany.com/subdirectory 
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Step 5. Running the JefSetup Program 

The JefSetup Program is located in Programs >Happen Business >Jim2 Ebusiness Suite >Jim2 eBusiness 

Framework Setup. 

 

 
 

Enter either the Directory or FTP details. See Deploy Path above for more Information. 
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Use the button with ... to enter the SQL server details in an easy form. See Database Connection String above for 

more Information. 

 

 
 

Next, Continue the Setup program following the instructions.  
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Troubleshooting  

During ‘Set web.config file’ you have the following error... 

 

Extracting Themes on Website, This could take several minutes. 

A WebException ocurred . 

This means you cannot connect to the remote server. 

- Please check the web server is running. 

Please check the URL is correct. 

An error occured extracting themes. Please check your ASP.NET access rights with your ISP. 

 

This means that the ASP.NET user account does not have FULL access rights to the web directory.  

 

a. If you use a hosting provider this means they have not set up the account correctly. Please contact them and tell 

them the ASP.NET user account needs write/delete access to the full website directory.  

b. If you are hosting internally please ask your web server administrator to set up the ASP.NET user account with 

write/delete access to the full website directory 

 

Step 6. Use the Jim2 CM to Set up Jes 

 

Summary 

We are now going to set up the Jes Instance on the Jim2 Server. We do this so Jef and Jes can have a communication 

line. Jef needs to communicate with Jes to obtain Jim2 data such as JobLists, MeterReads, and Service Requests. Jes 

needs to communicate with Jef in order to publish User accounts to the website. 

 

Publish Module – Looks after the publication of information from Jim2 Business Engine to Jim2 eBusiness Framework 

(Jef). 

 

TCP Module – Provides the Jef connectivity to Jes. This module is required by Jef when configured as ‘online’ and 

when obtaining Jim2 functionality such as JobLists, MeterReads and Service Requests. 

 

1. Open the Jim2CM from Program Files >Happen Business >Jim2 eBusiness Suite >Jim2 Configuration 

Manager 

4. If you have not created a new Jes Instance 

a) Click File >New Jes Instance 

b) Enter the database name 

c) Leave the default port of 5730 

5. Right Click the Jes Instance and open ‘Configure’ 

6. Set up the publish module. The publish module looks after the publication of information from Jim2 Business 

Engine to Jim2 eBusiness Framework (Jef). 
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7. Set up the TCP Module 
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8. To start the Jes Instance, select Jes from the grid and hit the run button.  
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Step 7. Set up Jim2, Web User and Contacts 

 

 
 

2. You will need to set up an Administrator that has Jef Administration access. 
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9. Enable a user for a web account 

 

 
 

10. Set up your customer web account 
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11. Emailing Passwords – Jim2 has the ability to email Login IDs and passwords.  

a. First you will need to set up the password email template, do this from Jim2 > Options > Cardfile. Under 

Password Welcome Email put in your Email Subject and Email Body. 

b. Use the %WebLogin% and %Password% Macros within the Email Body. 

 

Step 8. Restart Jes with the Publish Module Enabled 

 Restart Jes with the Publish Module Enabled. 

 Wait for a few minutes, while Jes performs its initial publication of data to Jef. 

 Attempt to log on with your user account. 

 Browse to the admin/admin.aspx in order to administer your website. 

 

Troubleshooting 

 

Cannot login with users with weblogins 

You can see if the users have been sent to the website from the eBusiness Transactions TAB from within Jim2.  

 

1. Go to eBusiness TAB. 

2. eBusiness Transactions > Outbound Queue. 

3. Select ‘Include Processed Requests’. 
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Step 9. Set up and Use the framework for eBusiness Service or Meter Reads 

 

 See Appendix A Framework Management Introduction 

 See Appendix B Design Mode Introduction 

 If you are interested in eBusiness  

 See Appendix C eBusiness Service Introduction 

 If you are interested in eMeterReads  

 See Appendix D eMeter Reads Introduction 
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Appendix A Website Management Introduction 
 

In order to customise eBusiness Service, you need to be familiar with the website management and design mode. 

 

1. Log on as a user with Web Administration Access.  

 

 
 

When logged on with Administration access you will notice a new menu item named Site Admin with two options – 

Manage and Design Mode.  

 

Manage – Is the site management area, which lets you manage functionality including Add Pages, Delete Pages, 

Edit Pages, Add Templates, Delete Templates, Global Module Settings, Site Settings, Publish Pages. 

 

Design Mode – Is the preview/edit area for the website. It lets you edit the website content, and update the 

module settings. 
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The pages area lets you: 

 

 Add Pages 

 Add Child Pages 

 Delete Pages 

 Rename pages 

 Add Modules to Pages 

 Set page templates 
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Templates are designs/content/master pages that are used by pages. A page must use a template. Here you can: 

 

 Add new templates based on different layouts.  

 You can set themes for templates.  

 You can add modules to templates. These modules will appear on all Pages that use the template. 
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Modules are modular pieces of functionality that can be placed on pages and templates. The Modules tab lets you 

provide global settings for Modules. So module settings can be done at a Global (Named Level) or a Page Level. 

 

 
 

Site Settings are general website settings. 

 

 SMTP Server is the email server provided by your ISP. 

 From Email is the email address that emails are sent from. 

 To Email is the email that administration notifications go to. 

 Access Denied Redirect is the landing page when a user is denied access to a page. 

 Internal Error Redirect is the landing page for a user when an error is encountered. 

 Tracking code is where you put tracking code supplied by google images. 
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When you make changes to the content and settings of the website, this is only reflected in ‘Design View’ it is not 

shown within the ‘Live’ view. In order to make your changes live you need to ‘Publish’ the changes. If have made 

mistakes in your ‘design’ view and want to revert your changes use the ‘Revert’ button. 
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Appendix B Design Mode Introduction 
 

To enter design mode go to Site Admin > Design Mode. 

 

 
 

‘Design Mode Header’ 

The design mode header contains links to the standard website management pages. It also contains the extra 

functionality of ‘Show/Hide Design Panels’ and ‘Logon Views’. 

 

The ‘Show/Hide Design Panels’ will enable you to toggle on/off the design panels, allowing you to see the website as it 

would look in ‘Live Mode’. 

 

The ‘Logon Views’ lets you switch the view within the Preview Area. For example, a Jim2 User will see their ‘JobList’ and 

‘Update Job’, whereas a Customer/Contact will see ‘add service request’. By using the Logon views, you can preview 

what each type of Logon will see when the website is published. 

 

Website Preview Area 

The website preview area shows a preview of the current page. You will notice dotted borders around parts of the 

preview area – these are the modules on the page/template. A blue dotted border indicates the module is on the 

page. A red dotted border indicates the module is on the template. 
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Common Module Settings 

 

The common settings are as follows: 

 

 Order No – The order in which the module appears in its section. 

 Panel Title – If you have chosen to use panels, this is the title of the panel on the website. 

 Show Panel – This determines if a Panel is shown or not. 

 Margins – These are the margins set on the panel, the margins should end with px. Eg. 10px. 

 

Custom Module Settings  

The custom module settings are settings that are specific for the module. For example, the HTML module has the 

ability to edit the HTML Content. 
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Appendix C eBusiness Service Quick Ooverview 
 

If you have installed the eBusiness Service Sample Website, this contains all the webpages set up.  

 

 
 

Customer View 

When you are logged on as a customer you are able to see Service Request, Service Request List, View Service Request.  
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Service Request 

 

 Customers are able to add service requests (Jobs).  

 When a service request is added a we can set a specific: 

 Job Item  

 Job Status 

 The fields on this form can be customised for your specific requirements. Fields that can be specified include: 

 Multiple columns can be added to a comment, so any generic fieldname can be made up and will go into a 

comment. For example if you had a custom requirement that needed customers to specify their ‘Computer 

Name’ this would be added to comments. 
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Service Request Settings 

To view the service request settings  

 

1. Log on as an Administrator. 

2. Go into ‘Design Mode’. 

3. Select Logon View > Contact. 

4. Go to the ‘service request’ page. 

5. Select the ‘Service Request Settings’ button. 

 

The fields are as follows: 

 

 Name – This is the ‘Named Module Settings’, which means this module with these settings can be put on multiple 

pages.  

 Job Item – This is the Item that the job is created under. 

 Jim Status – This is the Status that the Job is created under. 

 View Job Url – This is the URL (or hyperlink) that is used after a customer has entered a new Service and they select 

‘View Job’. 

 Job List Url - This is the URL (or hyperlink) that is used after a customer has entered a new Service and they select 

‘Job List Url’. 

 Fields – These are the fields you want on the service request form. 
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Service Request Fields 

 

 Order Number – is the order in which the fields appear on the form. 

 Field Type – This can be either text, multiline text, or dropdown list.  

 Text – A normal Text Box. 

 Multiline Text – This enables the customer to enter multiple lines . 

 Dropdown List – This lets you set a range of values that a user can input from a DropDown. This is good for 

fields such as Job Status, Priority etc. 

 Field Name.  

 Status – This is the job status, if you want to let the customer select from a list of statuses. 

 Customer Reference – Goes into the customer reference field on the job. 

 Priority - Goes into the Priority field on the job. It is best used with a DropDown List. 

 Type – This maps to the type field on the Job. It is best used with a DropDown List. 

 Invoice Description.  

 Fault Description. 

 In Comment – This field will go into a comment on the new job. This field can appear multiple times on the Job 

Form with different labels. 

 Label – This is the text that is used to describe the field to the customer. 

 Width, Height – Set the width and height. Multiline Texts are typically set to have a larger height. 

 Default Value – This is the default value that is set when a customer starts a new service request. 

 Warning Value, Warning Message – A service request has the ability to provide a warning message when a 

customer enters a certain value.  

 Optional – If this is not checked a user must enter a value for this field.  

 Visible – This hides a field from the customer. Typically you would do this so that you can enter a value for a field 

without letting the customer see this value.  
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Service Request List 

The service request list is a ‘Joblist’ that is customised for the customer. 
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Service Request List Settings  

To view the service request list settings  

 

1. Log on as an Administrator. 

2. Go into ‘Design Mode’. 

3. Select Logon View > Contact. 

4. Go to the ‘service request list’ page. 

5. Select the ‘Job List Settings’ button. 

 

The fields are as follows: 

 

 Name – This is the ‘Named Module Settings’, which means this module with these settings can be put on multiple 

pages.  

 Job Item – It is possible to force the customer to use a specific job item, therefore they will only see jobs with that 

specific Item. 

 Columns – These are the columns that you want listed for a customer. 

 Url – is used for Job#. You need to enter the URL of your UpdateJob/Service Request Page. 

 Url Name – Name displayed in the grid when a URL is used. 

 User Only – If this is checked the field will be displayed to Users only. 
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View Service Request  

The ‘View Service Request’ is an UpdateJob module that has been customised for the customer. The customer is able 

to: 

 

 View the Job Information. 

 View comments that are flagged as ‘Inc’. 

 Add Comments to a Job.  

 When customers add comments, emails can be sent to the ‘Name’ on the job, ‘Account Manager’ and other 

specified emails.  

 When customers add comments, the Job Status can be changed to a status that you have defined. This allows 

you to create a JobList with all the updated jobs. 
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View Service Request Settings 

To view the ‘View Service Request’ settings  

 

1. Log on as an Administrator. 

2. Go into ‘Design Mode’. 

3. Select Logon View > Contact. 

4. Go to the ‘View Service Request’ page. 

5. Select the ‘Module Settings’ button 

 

Details of Settings 

 

 Submit Redirect Page – is the page that the customer is redirected to after they update the job. 

 Hide (OurRef, ItemCode, Type, DateDue, AccMng, Invoice Desc, SerialNo, ItemDesc, JobType) will hide these fields 

on the form. 

 Email Name Cust Comment – If this is checked, the person named on the job will be emailed when a customer adds 

a comment to a job. 

 Email Mng Cust Comment – If this is checked, the account manager on the job will be emailed when a customer 

adds a comment to a job. 

 Email on Cust Comment – Here you can add an extra email address that is sent when a customer adds a comment 

to a job. 

 Status on Cust Comment – This is the status that the job is changed to when a customer comments on a Job. 



   

21/08/2015 12:49 PM                                           Page 29 of 36  

 

 
 

Jim2 User View 

The Jim2 User can see the ‘JobList’ and also the ‘Update Job’. 
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Jim2 User Update Job 

When logged in as a user you can do the following: 

 

 View Job Information. 

 Job Header Information. 

 Contact details for the Job. 

 Google Maps links for the Address. 

 Current Comments on the job. 

 Current Labour on the Job. 

 Update Job Information. 

 Update the Status for the Job. 

 Update the Fault Description on the Job. 

 Add comments to the Job. 

 Add Labour to the Job. 
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Appendix D How to Set up for Photocopier Page Counts 
 

1. Set up Website for page counts 

 

Note: In the installation there is a sample site which already has a photocopier website set up. This is 

recommended over manual configuration. 

 

Log on to your website as an administrator, go to ‘Manage Pages’ and add a new page. Give the new page a 

virtual path, 'Photocopier/PageCount', for example. Make the page accessible to contacts only. 

 

Add the Copier Page Count module to the page. 

 

If you want to allow customers to send copier service requests via your website you will also want to set up a 

copier service request page using the Copier Service module. 

 

2. Configure the Jim2 Options 

You’ll need to configure the Jim2 Options Machine Options so that you can send out request emails to the 

customers. To open up the Machine Options go to Tools -> Options -> Project -> Machines. 

  

a) Page Count Url is the URL to the MeterReads page for the website. By default this will be 

www.yourwebsite.com/MeterReads.aspx 

b) These are the available Macros for the emails. The most important one is <WEBSITEWITHLOGIN> which will 

send an email link directly to the website, and automatically log in the user. 

c) Templates need to be set up for Web Email and Text Email. Web Email will be used for machine configured as 

Web Email while Text Email will be for machine configured as Text Email. 
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3. Configure the Password Welcome Email 

In order to send out the customer’s username and password via Jim2 we need to set up the 'Password Welcome 

Email'. This is done in Jim2 Options under CardFile. 

 

 
 

4. Send the welcome email from CardFile 

Note: you will need to have the SMTP EMail Server set up in Jim2 Options. 

 

Note: Do not send the email until you have completed/confirmed the Jef installation. 

Use the Email Password Button from the CardFile. 

 

 
 

5. Set up Machines for Request By Web Email 

6.  

a) In each machine you are able to select 'Request By'. Change this to Web Email. Note: you are able to set up an 

individual contact that will receive the page requests and web logon.  

b) In CardFile, set up the 'Email Photocopier' (for each contact, including the primary contact). 

c) Run the 'Page Request Form' for a Machine or Machine List. 

Note: primary contacts will see a list of all the machines from the page counts webpage, while individuals will 

only see their machines.  
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FAQ 

Are there any other colour schemes available? 

 

Yes there are different colour schemes (themes). 

 

1. Log on as user with Administration access. 

2. Go to Manage from the Menu. 

3. Go to Templates. 

a) Edit the Template you would like to change the colour for. You will see an option named ‘Theme’. There are a 

range of themes that can be chosen. 

b) Save the Template. 

 

4. From the menu system go to design mode, and when in design mode navigate to a page with that template. 
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FAQ 

Can you please tell me how to change the Web based page to have our logo in the background? 

 

1. Log on as a user with Administration access. 

2. Go to Site Admin > Design Mode. 

3. Click Edit Html on the header. 

 

 
 

4. Click HTML view and delete all the contents. 
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5. Click to Upload your image. 

 

 

 

 
 

6. Then click ‘Save’ on the HTML edit form  
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Error: Resetting password gives this error to user. “The parameter 'address' cannot be an empty string. “ 

This could mean that the sender’s address within the website setup is not set.  

 

To set the email: 

 

1. Log in as a user with administrator access and select Site Admin >Manage. 

 

 
 

2. Go to the site settings link. 

3. Enter your SMTP server, From Email and To Email. 

 

 
 

For assistance or information please call Happen support on 02 9570 4696 or email support@happen.biz 

file:///C:/Users/lindac/Desktop/support@happen.biz

